lib/scripts/polyml-version
author wenzelm
Wed Jun 17 23:22:52 2009 +0200 (2009-06-17)
changeset 31695 36c5c15597f2
parent 29145 b1c6f4563df7
child 40546 f46c902a8438
permissions -rwxr-xr-x
more robust poly startup, by restricting heap size (otherwise it fails on very large memory);
removed Poly/ML 4.x variant;
     1 #!/usr/bin/env bash
     2 #
     3 # polyml-version --- determine Poly/ML runtime system version
     4 
     5 echo -n polyml
     6 
     7 if [ -x "$ML_HOME/poly" ]; then
     8   env LD_LIBRARY_PATH="$ML_HOME:$ML_HOME/../lib:$LD_LIBRARY_PATH" \
     9     DYLD_LIBRARY_PATH="$ML_HOME:$ML_HOME/../lib:$DYLD_LIBRARY_PATH" \
    10     "$ML_HOME/poly" -v -H 10 | \
    11     sed -n 's,^Poly/ML.*RTS version: [^ ]*\(-[^ ]*\).*$,\1,p'
    12 fi