Fri, 09 Jul 2010 16:58:44 +0200 pervasive success combinator
haftmann [Fri, 09 Jul 2010 16:58:44 +0200] rev 37758
pervasive success combinator
Fri, 09 Jul 2010 16:32:25 +0200 added "while_option", which needs no well-foundedness; defined "while" in terms of "while_option"
krauss [Fri, 09 Jul 2010 16:32:25 +0200] rev 37757
added "while_option", which needs no well-foundedness; defined "while" in terms of "while_option"
Fri, 09 Jul 2010 10:08:10 +0200 avoid slightly odd "M" suffix; rename mapM to fold_map (fold_map_abort would be more correct, though)
haftmann [Fri, 09 Jul 2010 10:08:10 +0200] rev 37756
avoid slightly odd "M" suffix; rename mapM to fold_map (fold_map_abort would be more correct, though)
(0) -30000 -10000 -3000 -1000 -300 -100 -30 -10 -3 +3 +10 +30 +100 +300 +1000 +3000 +10000 +30000 tip