lib/scripts/polyml-version
author wenzelm
Tue, 21 Nov 2006 18:07:33 +0100
changeset 21437 a3c55b85cf0e
parent 20758 19be439e35f9
child 21652 3501b5a8a2c1
permissions -rwxr-xr-x
moved theorem kinds from PureThy to Thm;

#!/usr/bin/env bash
#
# $Id$
#
# polyml-version --- determine Poly/ML runtime system version

echo -n polyml

if [ -x "$ML_HOME/poly" ]; then
  if [ -x "$ML_HOME/polyimport" ]; then
    env LD_LIBRARY_PATH="$ML_HOME:$ML_HOME/../lib:$LD_LIBRARY_PATH" \
      "$ML_HOME/poly" -v | \
      sed -n 's,^Poly/ML.*RTS version: [^ ]*\(-[^ ]*\).*$,\1,p'
  else
    "$ML_HOME/poly" -noDisplay -r /dev/null | head -n 1 | \
      sed -n 's,^Poly/ML RTS version [^ ]*\(-[^ ]*\).*$,\1,p'
  fi
fi